WorldWideScripts.net Delivering the best Add-Ons in more than 37 languages.

中文(简体), English, हिन्दी/हिंदी, Español/Castellano, العربية, Русский язык, Français, 中文 (台灣), বাংলা, Bahasa Indonesia, اردو, Português, Deutsch, Bahasa Melayu (بهاس ملايو‎), 日本語 (にほんご), فارسی, Italiano, తెలుగు, Türkçe, ગુજરાતી, Język polski/polszczyzna, Tiếng Việt, ಕನ್ನಡ, Українська мова, ไทย
PHP Scripts / Miscellaneous

PHP Version Finder

— Add-On til WorldWideScripts.net

Abonner på vores feed for at holde dig ajour !

Nyt! Følg os som du ønsker det!


PHP Version Finder - CodeCanyon Item for Sale

Ads

Ad: Bluehost hosting

Følg mig på Twitter Følg mig på G + Følg mig på CodeCanyon live-Demo

Demo - Ingen Database (lammet)
Demo - Database (lammet)
De demoer er lammet! Vi har forvrænget den sande version af hver funktion og udvidelse.

PHP Version Finder - Opdateret til v 1.0.3c 2010/12/09

Find hvilken version af PHP dit script kræver. Adspurgt om, hvad version af PHP kræves for at køre vores scripts havde vi ikke et endeligt svar. Vi skabte dette script til at bestemme PHP-version, og så tog vi det til et andet niveau ved at søge ud udfasede funktioner. Men vi stoppede ikke bare på det. Vi inkluderet PHP udvidelser og sproglige konstruktioner. Vi næsten kaldte det gode til det, men så vi spekulerede... hvor mange gange vi brugte disse funktioner. Overdreven anvendelse af den samme funktion kan nedbrydende på præstationen. Overvågning hvor mange gange en funktion bruges, kan hjælpe med at afgøre, om der kan skabes en "Bruger oprettet Function" for at reducere kode og øge ydeevnen.

Opdagelse

PHP Version Finder spor: 3044 PHP funktioner, 2260 PHP Extensions, 23 sprogkonstruktioner, 19 alternative forslag, 7 Tips / Tricks / Noter. (Plus 69 Eksperimentel, 20 Deprecated, 47 "svn" funktioner)
Koden behøver ikke at være komplet eller fungerer. Det behøver ikke engang at give mening. Så længe det er mellem <? Php og?> Det vil blive evalueret. Forkrøblet Demo - Demoen er blevet forkrøblet at forhindre folk i at bruge det i stedet for at købe det.

Stop gætte!

Sandheden skal frem - de fleste udviklere "kugle-park", hvilken version af PHP er påkrævet ved at minde et par "nøgle" funktioner, de brugte. Med PHP Version Finder kan du vide med sikkerhed, hvad PHP-version rent faktisk er nødvendige!
Må ikke gætte! - Kør PHP Version Finder på din script til at vide med sikkerhed, hvad verions af PHP er forpligtet til at betjene dit script!

forældet Detection

PHP Version Finder lader dig vide, hvis nogen funktioner, du anvendte forældet.
Forældet Detection - Tjek dine scripts til forældede funktioner

To versioner

PHP Version Finder ikke kræver en database. for dem af jer, der hellere vil bruge en database, scriptet omfatter dog en database version.
Optionhal Database - PHP-version finder ikke kræver en database, men er en alternativ version leveres til dem, der ønsker at bruge en database.
Hvorfor to versioner?
Det hele kommer ned til numre. Hvis der er masser af PHP funktioner, NON database version er hurtigere. Hvis der kun er et par funktioner, databasen version er hurtigere. Hvor meget hurtigere? Tja, det er målt i mikro sekunder. Så ikke virkelig mærkbar. Efter vi gjort database versionen besluttede vi, det ikke var værd som dens ydeevne ikke var mærkbar anderledes. Vi besluttede at medtage det, fordi det allerede var bygget - en freebie hvis du vil.

Installation

Installation er enkel. Upload mappen, redigere to indstillinger og du er færdig.
Installion - Upload en mappe til din server, redigere en config fil og din klar til at gå!

Indgange

Du kan uploade en fil fra din computer, scanne en fil eller hel mappe på serveren, eller pasta kode i en boks til forarbejdning.
Flere indgange - Du kan uploade en fil, scanne en mappe eller kontrollere en blok af kode.

Alternative forslag

Hvis PHP Version Finder finder funktioner, som forældede, vil det give dig alternative forslag, der kan erstatte den udfasede funktion.
Alternative forslag - Du kan lave dit script For eksempel:
hvis du bruger file_put_contents (som kræver PHP 5), vil PHP Version Finder fortælle dig, at du kunne bruge fwrite stedet, som kunne sænke krævede version ned til PHP 4. Ikke kun det, men der er en fodnote til file_put_contents der viser dig koden til at bruge til at gøre file_put_contents bagudkompatibel.

Køb PHP Version Finder NU!

Gør livet let! Find forældede funktioner, får baglæns kompatible forslag og vide, hvilken version af PHP er påkrævet for at køre dine scripts
Køb nu - Gør livet let, finde forældede funktioner, får bagudkompatibel forslag og vide, hvilken version af PHP er påkrævet for at køre dine scripts.

Aktuelle funktioner (v 1.0.0) - 12/1/2010

  • Valgfri Database
  • forældet Detection
  • Fil Upload Processing
  • Register Processing
  • Indsat Kode Processing
  • Autofuldførelse
  • Syntaks Highlighter
  • 3044 PHP funktioner
  • 2260 PHP udvidelser
  • 23 Sprog konstruktioner
  • 19 alternative forslag
  • 7 Tips / Tricks / Noter
  • Plus 69 Eksperimentelle funktioner
  • Plus 20 Forældet funktioner
  • Plus 47 "svn" / ukendte funktioner

Opdater v 1.0.1 2010/12/03

  • Faste Notice Advarsler
  • Faste "udefinerede variable" Fejl
  • Faste Spelling Fejl
  • Opdateret Hjælp-fil for at afspejle ændringer
  • Tilføjet Licensing Forklaring
  • Renset op "Rapport File"

Opdater v 1.0.2 2010/12/04

  • Faste Notice Advarsler
  • Faste "udefinerede variable" Fejl
  • Opdateret Hjælp-fil for at afspejle ændringer

Opdater v 1.0.3c 2010/12/09

  • Renset koden
  • Omskrev hvordan statistikker er optalt.
  • Omskrev "Rapport File"

Hent
Andre komponenter i denne kategoriAlle komponenter i denne forfatter
KommentarerOfte stillede spørgsmål og svar

Egenskaber

Oprettet:
3 december 10

Sidste ændring:
10 december 10

Høj opløsning:
Ingen

Kompatible Browsere:
IE7, IE8, Safari, Opera

Filer Inkluderet:
JavaScript JS, HTML, CSS, PHP, SQL

Software Version:
PHP 4.x, PHP 5.x, PHP 5,0-5,2, PHP 5.3, MySQL 5.x

Søgeord

eCommerce, eCommerce, Alle artikler, foræ, ldet advarsel, php-version, syntaksfremhæ, vning